YeomanでgenerateしたangularのプロジェクトでTravis.CIがビルドエラー

Travis CIでエラー

Travis CI でビルドエラーになる。 bower install でangular.jsのバージョン選べって言われちゃうから。 yo angularしただけだからなぁ。

Unable to find a suitable version for angular, please choose one:

1) angular#1.2.4 which resolved to 1.2.4 and has angular-mocks#1.2.6-build.1989+sha.b0474cb, angular-resource#1.2.6-build.1989+sha.b0474cb, angular-route#1.2.6-build.1989+sha.b0474cb, angular-sanitize#1.2.6-build.1989+sha.b0474cb, angular-scenario#1.2.6-build.1989+sha.b0474cb as dependants
2) angular#~1.2.0 which resolved to 1.2.6-build.1989+sha.b0474cb and has conchas-client-browser as dependants
3) angular#1.2.6-build.1989+sha.b0474cb which resolved to 1.2.6-build.1989+sha.b0474cb and has angular-cookies#1.2.6-build.1989+sha.b0474cb as dependants

Prefix the choice with ! to persist it to bower.json [?] Answer:

バージョンを指定して解決

~1.2.0ってなってたとこを1.2.4にした。

  "dependencies": {
    "angular": "1.2.4",
    "json3": "~3.2.4",
    "es5-shim": "~2.1.0",
    "jquery": "~1.10.2",
    "sass-bootstrap": "~3.0.0",
    "angular-resource": "1.2.4",
    "angular-cookies": "1.2.4",
    "angular-sanitize": "1.2.4",
    "angular-route": "1.2.4"
  },
  "devDependencies": {
    "angular-mocks": "1.2.4",
    "angular-scenario": "1.2.4"
  }